Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2018.1 is giving me the following error
#1
Note that when I do what Visual Studio suggests (by referencing that other class), it then complains about "WorldSpline" not being an enum.

Errors:

Assets/Packages/Curvy/Base/CurvyImportExport.cs(42,16): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(101,71): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(112,76): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(123,85): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(135,40): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(140,40): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(149,78): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?


Assets/Packages/Curvy/Base/CurvyImportExport.cs(154,83): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(159,92): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(164,58): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Assets/Packages/Curvy/Base/CurvyImportExport.cs(169,58): error CS0246: The type or namespace name `CurvySerializationSpace' could not be found. Are you missing `FluffyUnderware.Curvy.ImportExport' using directive?

Warnings:

Assets/Packages/Curvy/Base/CurvyUtility.cs(218,16): warning CS0436: The type `FluffyUnderware.Curvy.ThirdParty.LibTessDotNet.WindingRule' conflicts with the imported type of same name'. Ignoring the imported type definition

Assets/Packages/Curvy/Base/CurvyUtility.cs(241,9): warning CS0436: The type `FluffyUnderware.Curvy.ThirdParty.LibTessDotNet.Tess' conflicts with the imported type of same name'. Ignoring the imported type definition

Assets/Packages/Curvy/Base/CurvyUtility.cs(424,16): warning CS0436: The type `FluffyUnderware.Curvy.ThirdParty.LibTessDotNet.ContourOrientation' conflicts with the imported type of same name'. Ignoring the imported type definition


Attached Files Image(s)
       
Reply
#2
Hi,
Curvy is compatible with Unity 2018.1, so I don't think the error comes from the Unity version.
I am guessing that you had these errors after updating Curvy. If this is the case, please delete the Curvy folder before importing the new version.
If my guess is wrong, please tell me what action triggered these errors.
Please consider leaving a review for Curvy. This will help a lot keeping Curvy relevant in the eyes of the Asset Store algorithm.
Reply
#3
And as a best practice, always delete old version of assets (not only Curvy) before importing the newest version, because if the new version of the asset removed a file existing in the old version, the update process will not remove that file. Same thing for moved files.
Please consider leaving a review for Curvy. This will help a lot keeping Curvy relevant in the eyes of the Asset Store algorithm.
Reply
#4
(05-08-2018, 03:03 PM)_Aka_ Wrote: Hi,
Curvy is compatible with Unity 2018.1, so I don't think the error comes from the Unity version.
I am guessing that you had these errors after updating Curvy. If this is the case, please delete the Curvy folder before importing the new version.
If my guess is wrong, please tell me what action triggered these errors.

Bingo!  Thanks!  I tried reimport but that didn't work.  Delete/Import did though.
Reply
#5
Good to hear. Enjoy your updated Curvy.
Please consider leaving a review for Curvy. This will help a lot keeping Curvy relevant in the eyes of the Asset Store algorithm.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Issues with 2018.3.0f2 douoht 9 1,366 01-25-2019, 04:46 PM
Last Post: _Aka_
  'Ambiguous reference' error TenaciousLibbs 3 669 01-16-2019, 10:22 AM
Last Post: _Aka_
  Building error! am I something wrong? davide1104 2 530 01-10-2019, 10:27 PM
Last Post: _Aka_
  strange error pez111 5 1,834 12-23-2018, 04:34 PM
Last Post: _Aka_

Forum Jump: