Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Issues with generated meshes
#1
I'm trying to use a single spline and output a mesh in multiple pieces. Basically I want to create a race track, and for parts of the track I want different types of properties (assigned physical materials). Parts of the track should be asphalt, others should be dirt.

My setup is a single closed spline. The generator looks like this:
   

Part of the spline is used to create the dirt mesh, another part is used to output the asphalt mesh.

I'm running into issues with the resulting mesh however. Unless I turn off "Optimize" in the path extrusion, the results wont line up. This is what it looks like with it turned on:
   

Is there any way to make this work with optimized shapes?

Also, instead of using range/length in the shape extrusion, I tried using range options in the input spline. But I run into issues where the starting CP cant be "after" the end CP, even if the input spline is closed.

Am I going about this the right or wrong way?
Reply
#2
Hi,
Is it possible for you to send me either a reproduction case? If so, do not share it here, since this forum is public. Send it to me via PM or mail.
Also, what version of Curvy Splines do you use?
Have a nice day
Please consider leaving a review for Curvy. This will help a lot keeping Curvy relevant in the eyes of the Asset Store algorithm.
Reply
#3
For future reference:

There was a bug the Mesh Extrusion module, when using the advanced scaling when using a custom range that loops. The fix was found, and will be part of the next update. Contact me if you need the bug fix before that.

Also, keep in mind that using the same layer in Conform Path and the created mesh is rarely a good idea, since that will include the latter in geometry to conform against.
Please consider leaving a review for Curvy. This will help a lot keeping Curvy relevant in the eyes of the Asset Store algorithm.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Exclamation Fixes for known issues _Aka_ 1 4,644 11-23-2020, 11:55 PM
Last Post: _Aka_
  Batch processing of the Generator to create a bunch of Meshes HatraE 3 100 10-21-2020, 11:21 AM
Last Post: _Aka_
  Generated mesh using bezier spline is not following the path accurately processor 3 365 08-25-2020, 04:39 PM
Last Post: _Aka_
  Question regarding Spline Generated Path linkinballzpokemon 9 1,455 07-01-2020, 06:10 PM
Last Post: _Aka_

Forum Jump: