Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Custom Mesh Extrusion Problem
#1
Hi there,
great plugin so far, really intuitive and solid programming as well! I just ran into a problem I'm not sure how to solve. When I use the SplinePathMeshBuilder to extrude a custom mesh, I can't seem to get it to extrude right.

I am trying to extrude the following mesh:
[Image: cPHsmAJ.png]

Which results in the following:
[Image: 0rb0Z2r.png]

The extrusion mesh shipped with Curvy seems to work as intended:
[Image: 9cxQ3dO.png]

It appears that all the extruded faces seem to connect to the wrong vertices that don't really represent the original shape anymore. I am unsure how exactly the extrusion algorithm determines how to connect faces and was unable to get any custom mesh working. Even a simple quad seems to turn from a square tube into an "X" shape.

I have attached the mesh I am trying to extrude. The mesh was created in Blender (and is also attached as blend file). Did anyone else run into the same problem here? My guess would be that it's either a miscommunication between Blender created meshes and the SplinePathMeshBuilder or a general problem with it.

Thank you in advance.


Attached Files
.zip   ExtrusionShapes.zip (Size: 65.92 KB / Downloads: 5)
Reply
#2
Yes your result is already good i hope can calcul lightmap after Smile
here i get no more try at this time but i got no mesh visible in scene is maybie the size
i'am on xsi
Reply
#3
(08-11-2013, 01:44 PM)kilik Wrote: Yes your result is already good i hope can calcul lightmap after Smile
here i get no more try at this time but i got no mesh visible in scene is maybie the size
i'am on xsi

Thanks for the reply! Unfortunately I'm not sure I understand what you're trying to say. Undecided
Reply
#4
(08-11-2013, 11:42 AM)Kriechgebuesch Wrote: ... I can't seem to get it to extrude right... Did anyone else run into the same problem here? ...

Same issue for me.
Max
Reply
#5
(08-11-2013, 02:21 PM)SJM Tech Wrote:
(08-11-2013, 11:42 AM)Kriechgebuesch Wrote: ... I can't seem to get it to extrude right... Did anyone else run into the same problem here? ...

Same issue for me.
Max

Glad to hear I'm not alone. Are you using Blender as well ?
Reply
#6
Yes, I'm using your blend file and also with modifications but the result is wrong as your.
Reply
#7
(08-11-2013, 02:25 PM)SJM Tech Wrote: Yes, I'm using your blend file and also with modifications but the result is wrong as your.

Ah! So at least the problem is not specific to my system/setup somehow. Thanks for trying it out.
Reply
#8
you're welcome!

I did some test also with mesh generate inside unity with GameDraw ... same issue.


this mesh is a face of the standard unity cube primitive.


Attached Files
.zip   StdUCube_1Face_GDEdit.zip (Size: 916 bytes / Downloads: 1)
Reply
#9
(08-11-2013, 02:38 PM)SJM Tech Wrote: you're welcome!

I did some test also with mesh generate inside unity with GameDraw ... same issue.


this mesh is a face of standard unity cube.

I guess it is indeed a problem with the plugin then and not blender. That's good news I'd rather not use alternative methods to generate my extrusion meshes.
Reply
#10
It is a Curvy bug...could you report a bug with your screenshots and a link to this post to point this problem to Jake?
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Some times mesh distortion. mammuoils1 5 217 12-24-2019, 05:40 PM
Last Post: _Aka_
  Shape Extrusion Scale maabed 5 379 11-06-2019, 04:14 PM
Last Post: _Aka_
  Same Spline Extrusion with variable width MarioBag 5 1,127 11-04-2019, 01:56 PM
Last Post: _Aka_
  Custom module spits a lot of errors Tim1234 5 345 10-24-2019, 04:36 PM
Last Post: _Aka_

Forum Jump: