Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Errors after update
#1
I updated curvy today and getting this error:

Assets/Packages/Curvy/Base/CG/CGModule.cs(506,41): error CS0121: The call is ambiguous between the following methods or properties: `FluffyUnderware.DevTools.Extensions.ArrayExt.RemoveAt<FluffyUnderware.Curvy.Generator.CGDataRequestParameter>(this FluffyUnderware.Curvy.Generator.CGDataRequestParameter[], int)' and `FluffyUnderware.DevTools.Extensions.ArrayExt.RemoveAt<FluffyUnderware.Curvy.Generator.CGDataRequestParameter>(this FluffyUnderware.Curvy.Generator.CGDataRequestParameter[], int)'



and a similar error is showing up for almost every extension method

nevermind, looks like there was a naming conflict with having two "SceneSwitcher" scripts from unrelated plugins in my project
Reply
#2
looks like something went wrong on import. Try deleting the packages/curvy and packages/devtools folder and reimport. Everything should be fine then.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Creting SplineControllers thru code generating errors curvyuser007 7 1,137 06-07-2020, 04:19 PM
Last Post: curvyuser007
  Lots of Allocs in Editor Update (Poor Performance in Editor) TdayMFG 4 1,428 02-06-2020, 10:13 PM
Last Post: _Aka_
  Custom module spits a lot of errors Tim1234 5 1,807 10-24-2019, 04:36 PM
Last Post: _Aka_
  Disable the Update of the CurvySpline UsernameHed 8 3,538 05-29-2019, 01:13 PM
Last Post: _Aka_

Forum Jump: